Forum Index

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

I got a Vibratone!

 
Post new topic   Reply to topic     Forum Index -> Amps
View previous topic :: View next topic  
Author Message
getbent



Joined: 11 Sep 2006
Posts: 116
Location: San Benito, CA

PostPosted: Tue Jun 03, 2008 4:03 am    Post subject: I got a Vibratone! Reply with quote

I'm pretty excited. I traded a blues deluxe for it... and was pretty excited when I got there and it was fired up... it sounds cool!




I was pretty happy to find it and get it!
Back to top
View user's profile Send private message AIM Address
Silverface



Joined: 23 Aug 2006
Posts: 324
Location: Hermosa Beach CA

PostPosted: Tue Jun 03, 2008 3:40 pm    Post subject: Reply with quote

Did you get the footswitch/crossover with it? Or is it one that's been wired as an extension cabinet?

If so, I encourage you to get the crossover (a couple places have them online) - it's the real key to the sound, throwing all the mids to the Vibratone and the highs/lows to the guitar amp speakers. The difference is absolutely incredible. I've had it both ways, and wouldn't touch one without the crossover (which also has the speed switch).

Also, the stock speakers in them are downright awful. A 10" Utah that sounds like it has a down comforter thrown over it. It's a bit tricky (but helps you learn how to maintain it...and if you don't have the manual I can get you one) but a speaker change to a Weber California is incredible - literally doubles the output with much richer harmonics. The Weber will also handle more power; you CANNOT use that thing with a Twin or any 100-watt amp, as the speaker's only rated for around 30 watts and will have degraded down to about 20-25 watts of power handling by now. I'd change it before you blow it, and put a 100-watt speaker in it just for safety. If you like a little more gritty tone, the Weber Chicago is my next favorite.
Back to top
View user's profile Send private message Visit poster's website
getbent



Joined: 11 Sep 2006
Posts: 116
Location: San Benito, CA

PostPosted: Tue Jun 03, 2008 5:05 pm    Post subject: Reply with quote

Jim,

I played it when I made the trade but haven't had time (friggin' little league and school awards ceremonies) to fire it up and figure it out...

it has a footswitch with two buttons (I'll take some pics) that is definitely not original but worked fine... there are 3 different 1/4 cable jacks on the back although I got the feeling that 2 are non operational or the owner did not know what they did.

I don't know jack about this so I really appreciate the education! I'll get a little time in a couple of days and I'll take a bunch of pictures... we'll see what i've got and what i need to do...
Back to top
View user's profile Send private message AIM Address
Silverface



Joined: 23 Aug 2006
Posts: 324
Location: Hermosa Beach CA

PostPosted: Wed Jun 04, 2008 5:25 am    Post subject: Reply with quote

Email me the pics if you want, plus one of the back of the vibratone where the jack(s) are. We'll get it working if you have a metal tubular part that came along with the footswitch and cables...that's the crossover...if not, we'll find one. You will flip out at the difference!
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Amps All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group